Email invitations
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Aug 13, 2018 - 14:21 UTC
Investigating
We’re currently experiencing intermittent email invitations problems. Our Operations Team is looking into it and will bring back full service soon. You may have to send the conference information in any other way available to ensure your invitees have the call information.
Posted Aug 13, 2018 - 13:51 UTC
This incident affected: Email Notifications.