FreeConference.com service interruption
Incident Report for FreeConference
Resolved
Service is now fully restored the following dial-in numbers as of 8/20/19 1:30pm PST
Posted Aug 20, 2019 - 20:33 UTC
Identified
We are currently experiencing technical difficulties with some dial in numbers accepting access codes

We are diligently working to resolve this issue.

In the meantime, please feel free to use the online meeting room.
Posted Aug 20, 2019 - 19:00 UTC
This incident affected: Join Calls by Phone.