IOS App call page not loading
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Nov 17, 2017 - 18:59 UTC
Investigating
We have identified a problem when trying to call using the IOS app. We will update when the issue is resolved
Posted Nov 16, 2017 - 18:46 UTC