Some users may have difficulties accessing their conference lines via phone
Incident Report for FreeConference
Resolved
The issue has been resolved and service is fully restored. Thank you for your patience.
Posted Mar 19, 2018 - 17:00 UTC
Investigating
Some users may have difficulties accessing their conference lines via the telephone dial-in numbers. We sincerely apologise for the issues, we are working on resolving this as quickly as possible.
Posted Mar 19, 2018 - 16:23 UTC