Intermittent phone access
Incident Report for FreeConference
Resolved
The dial-in number 605-562-0400 is now working without any service disruption.
Posted Jul 02, 2018 - 14:03 UTC
Investigating
The dial-in number 605-562-0400 is currently experiencing intermittent access to the call. Please use 1-605-475-4120 or any of the other available numbers provided for the call.
Posted Jun 29, 2018 - 21:44 UTC
This incident affected: Join Calls by Phone.