Audio issues with 44 333 011 0616
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 15:32 UTC
Investigating
Some callers are having issues calling our free UK number. We are investigating with our carrier to resolve asap. In the meantime if participants are joining this number and unable to hear, they can join online or by calling our alternative UK dial in 03330110940
Posted Jun 30, 2020 - 17:37 UTC
This incident affected: Join Calls by Phone.