Log in technical difficulties
Incident Report for FreeConference
Resolved
Logging in to accounts is now back to normal
Posted Jun 12, 2019 - 01:21 UTC
Investigating
We are currently experiencing log in difficulties through the main site. In the meantime, please use https://hello.freeconference.com/login to access your account
Posted Jun 12, 2019 - 00:45 UTC
This incident affected: Account Logins.