Unable to join calls by internet or phone
Incident Report for FreeConference
Resolved
The issue was escalated to our Operations team, who identified the failed system and restored services.
Posted Mar 23, 2018 - 08:41 UTC
Investigating
We are currently investigating an issue preventing callers from joining conferences by phone or internet.
Posted Mar 23, 2018 - 08:22 UTC