Credit Card Error Message
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 00:00 UTC
Identified
Our credit card processing merchant is currently have an outage, and we are unable to receive payments of any kind. This will be resolved as soon as their service is re-established. Conferencing services should be unaffected.
Posted Dec 09, 2019 - 22:56 UTC
This incident affected: New Account Signups.