FreeConference.com website service interruption
Incident Report for FreeConference
Resolved
Service is now fully restored as of 10/1/19 4:00pm PST.
Posted Oct 01, 2019 - 23:01 UTC
Identified
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.

Note that your telephone services have NOT been impacted in any way.
Posted Oct 01, 2019 - 22:48 UTC
This incident affected: Join Calls by Internet, Online Meeting Room, Account Logins, and New Account Signups.