Dial In Number Outage
Incident Report for FreeConference
Resolved
This issue has been resolved. All dial in numbers are now working as expected
Posted May 02, 2019 - 23:52 UTC
Update
We are continuing to investigate this issue.

Currently (712) 832 8330 is functioning correctly.
Posted May 02, 2019 - 23:28 UTC
Investigating
A number of our US based dial in numbers are currently unavailable. We are investigating the issue and will have a resolution soon
Posted May 02, 2019 - 23:27 UTC
This incident affected: Join Calls by Phone.