FreeConference.com mobile apps temporarily unavailable
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 18:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Please connect to your conference via computer or use the dial-in number and access code.
Posted Feb 26, 2020 - 14:16 UTC
This incident affected: Mobile (iOS / Android) Apps.