FreeConference.com service interruption
Incident Report for FreeConference
Resolved
Service is now fully restored to 1 712 832 8330 and some other 712 areas code dial-in numbers as of today (Sept. 17th, 2019) at 11:56 AM ET / 08:56 AM PT.
Posted Sep 17, 2019 - 16:13 UTC
Identified
Callers using AT&T may experience difficulties calling into 712 area code dial-ins.

We are diligently working to resolve this issue.

In the meantime, please use any of the following dial-in numbers with the same access code:

1 218 339 7800
1 605 562 0400
Posted Sep 17, 2019 - 12:21 UTC
This incident affected: Join Calls by Phone.