Scheduled maintenance still currently in progress. We will provide updates as necessary.
Incident Report for FreeConference
Resolved
Maintenance now completed
Posted Dec 29, 2018 - 04:08 UTC
Identified
Our service is temporarily unavailable due to scheduled maintenance today, Friday December 28th, from 3:00 PM through approximately 11:00 PM Eastern. Please call 1-312-600-1452 and your assigned access code to join your call (no recording available). Participants in the UK may dial +44 333-113-0093 to join their conference. We apologize for the inconvenience.
Posted Dec 29, 2018 - 02:07 UTC
This incident affected: Join Calls by Internet, Join Calls by Phone, Online Meeting Room, Video Conferencing, Account Logins, New Account Signups, Scheduling Dashboard, Screen Sharing, Document Sharing, Mobile (iOS / Android) Apps, and Email Notifications.