Conferencing services are experiencing technical difficulties
Incident Report for FreeConference
Resolved
Full services are now restored. We apologize for any inconvenience.
Posted Jul 22, 2019 - 21:08 UTC
Update
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2019 - 20:52 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2019 - 20:49 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2019 - 20:46 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2019 - 20:45 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2019 - 20:35 UTC
Investigating
We are currently investigating issues with online and phone access. We will update you as soon as possible.
Posted Jul 22, 2019 - 20:34 UTC
This incident affected: Join Calls by Internet, Join Calls by Phone, and Online Meeting Room.