Some callers may be unable to connect their audio when joining a call via internet
Incident Report for FreeConference
Resolved
This incident has been resolved. You may now join calls via internet as normal.
Posted Apr 24, 2019 - 14:35 UTC
Identified
The issue has been identified and a fix is being implemented. Please call via phone for now to connect your audio.
Posted Apr 24, 2019 - 14:25 UTC
This incident affected: Join Calls by Internet.